algobox

Algorithme de résolution des équations du second degré : Algorithme avec algobox


Mise à jour le 5 octobre 2014  |   Signalez une ERREUR  | 

algobox https://www.mathovore.fr/wp-content/uploads/2014/07/algobox.jpg https://www.mathovore.fr/wp-content/uploads/2014/07/algobox-300x288.jpg0 https://www.mathovore.fr/algorithme-de-resolution-des-equations-du-second-degre-algobox-149#respond
164

Voici un algorithme de résolution de l'équation du second degré :

ax^2+bx+c\,(a\neq0)

Entrées :

Saisir a,b,c (a non nul)

Traitement :

D prend la valeur   b^2-4ac 

Afficher D

     Si D>0 alors

                  X prend la valeur \frac{-b-\sqrt{D}}{2a}

                 Y prend la valeur \frac{-b+\sqrt{D}}{2a}

                 Afficher X,Y

   FinSi

  Si D=0  alors

              X prend la valeur -\frac{b}{2a}

             Afficher X

  FinSi

  Si D<0 alors

                Afficher "Pas de solutions"

  FinSi

       

1. Coder cet algorithme dans un langage de programmation avec votre calculatrice ou algobox .

2. Exécuter le programme obtenu avec a=1, b= – 5 et c= 6.

 

Algorithme de résolution des équations du second degré : Algorithme avec algobox
4 (80%) 1 vote



Les derniers topics du forum

Retrouvez les derniers topics ajoutés et des demandes d'aide formulées par les élèves. Une communauté dynamique d'aide en ligne qui vous permettra de résoudre vos exercices, DM ou de résoudre un problème dont vous n'arrivez pas à trouver la solution.


D'autres documents similaires

Inscription gratuite à Mathovore. Rejoignez les 132253 Mathovoristes, inscription gratuite.

https://www.mathovore.fr/wp-content/uploads/2014/07/algobox.jpg
Mathovore

GRATUIT
VOIR