algobox

Algorithme de dichotomie : Algorithme avec algobox


Mise à jour le 27 juillet 2014  |   Signalez une ERREUR  | 

algobox https://www.mathovore.fr/wp-content/uploads/2014/07/algobox.jpg https://www.mathovore.fr/wp-content/uploads/2014/07/algobox-300x288.jpg0 https://www.mathovore.fr/algorithme-de-dichotomie-algobox-148#respond
117

f est la fonction sur [0;1] par :

f(x)=x^3+2x-1.

1. Tracer la courbe représentative de f à l’écran de votre calculatrice.

2. On considère l’algorithme ci-dessous :

Initialisations :

a prend la valeur 0

b prend la valeur 1

Traitement :

Tant que b-a > 0,01

m prend la valeur \frac{a+b}{2}

Si f(m)>0 alors

b prend la valeur m

sinon

a prend la valeur m

FinSi

FinTantque

Sorties :

Afficher a,b

1. Expliquer le rôle de cet algorithme .

2. La condition b-a>0,01 qui gère la boucle peut-elle être modifiée ?Expliquer.

3.a. Traduire cet algorithme dans un langage de programmation avec algobox ou votre calculatrice.

b. Saisir le programme obtenu à la calculatrice ou à l’ordinateur.

c. Vérifier le fonctionnement du programme.

Algorithme de dichotomie : Algorithme avec algobox
Voter pour cette fiche



Les derniers topics du forum

Retrouvez les derniers topics ajoutés et des demandes d'aide formulées par les élèves. Une communauté dynamique d'aide en ligne qui vous permettra de résoudre vos exercices, DM ou de résoudre un problème dont vous n'arrivez pas à trouver la solution.


D'autres documents similaires

Inscription gratuite à Mathovore. Rejoignez les 130110 Mathovoristes, inscription gratuite.

https://www.mathovore.fr/wp-content/uploads/2014/07/algobox.jpg
Mathovore

GRATUIT
VOIR