Aide algo


Aide algo Niveau :
Posté par Psychedelic

Psychedelic

Bonjour, je viens tout juste de commencer à utiliser Algobox.

Mon Prof m'a demander de l'utiliser pour débuter en programmation d'algorithme.

Cependant, je n'arrive pas à comprendre la logique de cet exercice.

 

On me demande de conçevoir un programme dont je dois rentrer le prénom, nom, salaire et le pays de 40 clients... Par la suite le programme devra afficher les clients gagnants 50 000$ et plus dont le prénom est Marc et calculer le nombre de clients (50K et + qui se nomme Marc)

 

Voici mon algorithme....

1   VARIABLES
2     prenom EST_DU_TYPE CHAINE
3     nom EST_DU_TYPE CHAINE
4     pays EST_DU_TYPE CHAINE
5     salaire EST_DU_TYPE NOMBRE
6     compteur EST_DU_TYPE NOMBRE
7     i EST_DU_TYPE NOMBRE
8   DEBUT_ALGORITHME
9     compteur PREND_LA_VALEUR 0
10    POUR i ALLANT_DE 1 A 40
11      DEBUT_POUR
12      LIRE prenom
13      LIRE nom
14      LIRE salaire
15      LIRE pays
16      FIN_POUR
17    SI ((salaire>=50000) ET (prenom=="Marc")) ALORS
18      DEBUT_SI
19      compteur PREND_LA_VALEUR compteur+1
20      AFFICHER prenom
21      AFFICHER " "
22      AFFICHER compteur
23      FIN_SI
24    AFFICHER " ---- FIN ----"
25  FIN_ALGORITHME

 

Je n'arrive pas à trouver comment faire pour que ma boucle garde en mémoire tout les prénoms des clients (chaîne de caractère) et qu'ensuite je puisse les faire ressortir après mes conditions pour faire fonction ma condition SI...

Je vous remercie de votre aide à l'avance

 


Règles à respecter sur le forum

infoSi vous n'avez pas fait l'effort de préciser et rédiger ce que vous avez déjà fait et sur quels points vous êtes bloqué(e), vous risquez de ne pas recevoir de réponse.

Règles du forum - Ecrire une formule - Insérer une image - Liste des admins


Aide algo Posté le 12/05/2014 - 15:03

Posté par Psychedelic1 points


Psychedelic

wow.. c'est epic comment vous etes une gang de lâche... 44 View.. pas un criss de commentaire







Ce topic Aide algo est fermé, aucune réponse ne peut y être apportée .


Besoin d'aide?Créez un topic sur le forum Besoin d'aide? Créez un topic sur le forum.


Les derniers topics du forum

Retrouvez les derniers topics ajoutés et des demandes d'aide formulées par les élèves. Une communauté dynamique d'aide en ligne qui vous permettra de résoudre vos exercices, DM ou de résoudre un problème dont vous n'arrivez pas à trouver la solution.



D'autres documents similaires

Inscription gratuite à Mathovore. Rejoignez les 129924 Mathovoristes, inscription gratuite.

Revenir en haut de la page